Installer le Noyau Linux 3.8 (Stable) sur Ubuntu et Linux Mint.

Avertissement :

Avant de vous lancer sachez que cette manipulation n’est pas sans risques. Si vous n’êtes pas un familier des environnements GNU/Linux, que vous ne savez pas récupérer un système endommagé ou devenu instable, passez votre chemin… Dans tous les cas pensez à effectuer une sauvegarde de votre système avant de commencer.

Linus Torvalds a annoncé la sortie du noyau Linux en version 3.8 stable (ou pas), qui apporte son lot d’améliorations et et la prise en charge de toujours plus de périphériques.

Ce nouveau Kernel 3.8 améliore le support des cartes graphiques de dernière génération dont entre autres, le nouveau Haswell Intel, les nouveaux GPU Nvidia, AMD et dans un autre registre, le support des pilotes libres. Il améliore également le support pour F2FS, le système de fichiers développé par Samsung visant à améliorer la gestion de données dans la mémoire flash des appareils mobiles, usb pendrive, appareils photo, etc …

Les développeurs ont également travaillé dur afin d’améliorer le soutien des systèmes de fichiers Ext4, Btrfs et afin d’améliorer le soutien des processeurs ARM.

On notera également l’intégration de certains patchs permettant de réduire la consommation de RAM dans différentes situations.

    Voici un extrait du changelog :

  • Ajout du support pour le système de fichiers Samsung F2FS
  • Amélioration des performances pour Btrfs
  • Amélioration du support pour la gestion d’énergie (ACPI)
  • Support amélioré pour les pilotes audio
  • Abandon du support des CPU Intel 386
  • Optimisation AVX
  • Amélioration des performances pour les processeurs AMD Radeon / Nvidia
  • Ajout du support pour les processeurs Intel « Haswell » CPU

Si ça vous branche, vous trouverez l’intégralité du changelog sur cette page. La version 3.8 du Noyau Linux sera sans doute celle qui sera embarquée d’office dans Ubuntu 13.04.

En attendant, si vous êtes un grand cascadeur dans l’âme et que vous avez envie d’essayer le bel animal, vous pouvez installer le noyau Linux 3.8 stable (ou pas) sur Ubuntu et Linux Mint, à l’aide de ces quelques lignes de commandes :

Edit :

[Correction du lien]

cd /tmp/
wget http://dl.dropbox.com/u/964512/lffl_kernel/kernel-3.8 -O kernel-3.8
chmod +x kernel-3.8
sudo sh kernel-3.8
sudo reboot

En cas de soucis avec votre carte graphique Nvidia ouvrez une session en mode console et entrez ces quelques lignes dans votre termminal :

cd /usr/src/linux-headers-3.8.0-030800/arch/x86/include
sudo cp -v generated/asm/unistd* ./asm
sudo apt-get install --reinstall nvidia-current

Si vous voulez désinstaller la bête entrez ceci dans votre terminal :

sudo apt-get purge linux-image-3.8.0*

Amusez-vous bien.

Moo !!!

source


9 Responses

  1. Esykie 25 février 2013 / 0 h 55 min

    C’est miraculeux sur EeePc 1005px ! Je ne sais pas ce qu’ils ont fait, mais ça tourne extrêmement bien en 64bits sous Unity avec 1Go (mieux qu’avec le 3.2, beaaaaauuucoup mieux)

    • noireaude 25 février 2013 / 3 h 19 min

      Tant mieux! C’est toujours un peu la roulette Russe, donc je suis content que ça t’ai apporté un +.
      Moo !!!

  2. noireaude 21 février 2013 / 17 h 08 min

    Effectivement il y a appremment un gros soucis avec certaines cartes graphiques nVidia si j’en crois les commentaires du billet source. En revanche ça a l’air assez aléatoire en fonction de la version du pilote et ou de la carte grahique.
    Grand cascadeurs seulement quoi :)

  3. Sogy 21 février 2013 / 9 h 43 min

    Bonjour ,

    Sur mon portable avec une HD3000 , impec
    Par contre sur mon fixe avec une Nvidia (9300) impossible de l’installer , malgré un sudo apt-get install –reinstall nvidia-current
    qui d’habitude règle le problème à chaque changement de noyau.
    Quel driver nvidia faut il installer ?

    • A. 21 février 2013 / 10 h 44 min

      Faut voir ce que tu appelles « impossible de l’installer », tu as un message d’erreur ? Un écran noir ?
      Je suppose que tu as tenté la méthode ci-dessus (il y a un « cp » à faire avant de réinstaller nvidia-current), si tu es en 64 bits il faudra peut-être adapter le dossier (changer le x86).
      Tu peux aussi essayer d’installer le pilote « Nouveau » (pilote libre pour nVidia), qui a été amélioré avec cette version 3.8, mais il n’est pas aussi complet que le pilote proprio…
      Peut-être aussi que le pilote nVidia n’a pas encore été mis à jour pour le noyau 3.8 et que c’est juste une question de temps ;)

      • sogy 21 février 2013 / 18 h 28 min

        Merci , effectivement il y a bien un message « driver incompatible » qui s’affiche. J’ai la version 304.43
        Y a t il une version minimum à installer sachant que les 310.xx

        ne veulent pas s’installer correctement ?

  4. post-pc 20 février 2013 / 15 h 38 min

    ca marche pas la 1ere ligne le lien a lair mort !

    • A. 20 février 2013 / 17 h 28 min

      Chez moi le lien fonctionne, mais il manque un retour à la ligne après « cd /tmp ». En gros, ça donne ceci :
      [code]
      cd /tmp/
      wget http://dl.dropbox.com/u/47950494/upubuntu.com/kernel-3.8 -O kernel-3.8
      chmod +x kernel-3.8
      sudo sh kernel-3.8
      sudo reboot
      [/code]
      Notez que le lien en question est juste un script qui va télécharger les paquets ailleurs, c’est toujours mieux d’y jeter un œil avant de le lancer en Root ;)

      • post-pc 20 février 2013 / 18 h 19 min

        ok merci

Comments are closed.