YACReader – Un lecteur de BD numériques à tester absolument sous GNU/Linux, Windows, OS X et iOS

YACReader_interface

Si comme moi vous adorez l’informatique et dévorer des BD, cela fait sans doute longtemps que vous êtes passé à l’air du (tout) numérique et que vous tâtez du Comics sur votre PC ou sur un terminal mobile. Vous avez sans doute au passage testé pas mal d’applications dédiées à cette tâche et que vous ayez trouvé votre bonheur ou non, je pense que vous devriez (absolument) essayer YACReader si vous ne le connaissez pas encore. Il s’agit d’une application multiplateformes publiée sous licence GPL 3, qui a l’avantage de supporter un grand nombre de formats (rar, zip, cbr, cbz, tar, pdf, 7z, cb7, jpeg, gif, png, tiff, etc) et qui dispose de quelques options pratiques et très intéressantes. Si ça vous tente nous allons voir ça d’un petit peu plus près.

Alors en termes de fonctions, on pourra commencer par évoquer un mode défilement automatique (clavier/souris) qu’il n’est pas possible de montrer ici, mais qui consiste en gros à pouvoir faire défiler une planche ou du texte au survol du curseur. Vous ne serez donc plus obligé de scroller.

YACReader dispose également d’une fonction Pageflow, qui comme vous pouvez le voir ci-dessous va vous permettre de faire défiler les pages de votre document et de naviguer rapidement dans ce dernier.

YACReader-coverflow

Une fois activé il s’affiche au survol du curseur et bien que ce mode soit plus utile sur du tactile (tablettes, smartphones), il n’est pas dénué de charme sur un PC. Pour ceux qui connaissent il est assez similaire au mode CovertArt disponible sur Rhythmbox via un plugin.

Vous pourrez choisir entre différents modes de vues depuis le menu des paramètres de l’application et vous pourrez en prime en ajuster les performances, en fonctions des capacités de votre PC. C’est un détail vraiment très intéressant dans le sens où bien souvent ce genre de fonctions est intégré sans possibilités de réglages, les rendant inutilisables sur des machines modestes.

YACReader_paramètres

Si vous avez les yeux un peu fatigués ou que le document que vous lisez est de mauvaise qualité, vous pourrez bien entendu zoomer ou encore mieux, utiliser la loupe intégrée. Il vous suffira alors de déplacer le curseur pour élargir la zone concernée en temps réel. C’est super fluide et franchement TOP.

YACReader_loupe

La fonction marque-pages est elle aussi au top et va vous permettre de retrouver les pages que vous avez marqué en un  clic, ou de reprendre rapidement là où vous vous étiez arrêtés. Rien de plus à dire là-dessus, si ce n’est que c’est super pratique.

YACReader_marques-pages

Pour le reste on pourra également relever la présence d’un grand nombre de raccourcis claviers et la présence d’options plus classiques telles que :

  • la rotation d’images
  • une fonction de Zoom
  • l’ajustement en largeur/hauteur
  • un mode plein écran
  • un mode double vue
  • une visionneuse intégrée  (diaporama) possédant différents effets de transitions
  • un moteur de recherche intégré
  • un gestionnaire de bibliothèque(s)
  • un background personnalisable (couleur)
  • un dictionnaire

et une machine à café (je déconne hein)…

Conclusion :

Comme vous avez pu le constater YACReader est une alternative très complète, à laquelle il ne manque pas grand-chose. Elle est super sympa à utiliser et contrairement à beaucoup d’autres applications bardées de fonctions, elle est super fluide et légère à utiliser.

La seule chose que je pourrais lui reprocher en étant à la base sous un environnement GTK, c’est son interface basée sur Qt5 qui nécessite l’installation de pas mal de dépendances. À ce propos et en toute objectivité (il bien faut se rendre à l’évidence) Qt est en train de faire d’énormes progrès et commence vraiment à dépoter du poney.

Si vous voulez en savoir plus sur YACReader vous pouvez visiter le site officiel du projet (voir le lien plus haut), mais le mieux reste bien entendu de l’essayer. Vous trouverez ce qu’il vous faut pour Ubuntu, les autres distributions GNU/Linux, MS Windows, Mac OS X et iOS, sur la page de téléchargement du projet.

Notons au passage qu’une version portable est disponible, mais que les binaires fournis sur le site ne sont disponibles qu’en version 64 bits (pas glop). Si vous tournez sous GNU/Linux pensez aussi à installer « poppler-qt5″ via vos dépôts officiels, afin que l’application puisse s’exécuter correctement.

Debian, Ubuntu :

sudo apt-get install libpoppler-qt5-1

Fedora :

sudo yum install poppler-qt5

Arch Linux, Manjaro et dérivés :

sudo pacman -Sy poppler-qt5

Enfin, si vous tournez sous Archlinux et Manjaro, sachez que vous pouvez installer YACReader via AUR.

Amusez-vous bien.

via




17 Responses

  1. red 14 juillet 2014 / 0 h 33 min

    Je n’arrive pas a l’installer sur Arch.
    Si j’essaye de récupérer depuis AUR :

    ==> ERREUR : Erreur lors du téléchargement de yacreader-6.5.3.tar.gz
    Abandon…
    ==> ERREUR: Makepkg n’a pas pu construire yacreader-bin.

    J’ai essayé en récupérant l’archive sur le site officiel mais lors de l’installation ;

    erreur : méta-données du paquet manquantes dans YACReader-7.0.1-X11-x64-qt5.tar.gz
    erreur : ‘YACReader-7.0.1-X11-x64-qt5.tar.gz’: paquet invalide ou corrompu

    Un coup de main ? Merci.

    • Noireaude 14 juillet 2014 / 19 h 42 min

      Je pense qu’il s’agit d’un problème lié au package et au dépôt. Ça arrive souvent avec AUR. Quand c’est le cas j’attends un peu et je réessaye, ou j’essaye de prévenir le mainteneur du paquet.

  2. GPatterson 13 juillet 2014 / 12 h 42 min

    Je vais Yacreaderiser, merci.

  3. mikaji 11 juillet 2014 / 2 h 10 min

    Sinon, je dois avoir un bordel niveau source de paquets : sous mon ubuntu, impossible de trouver « libpoppler » et encore moins « libQt5Script » sans laquelle YACReaderLibrary ne veut pas fonctionner.

    Le reader est par contre vraiment excellent.

    • mikaji 11 juillet 2014 / 17 h 50 min

      dépot universe… Fucking mise a jour qui me les avait désactivés.

      • Noireaude 11 juillet 2014 / 19 h 04 min

        Arf, c’est balot :D

  4. loup 9 juillet 2014 / 20 h 26 min

    ubuntu 14.04 dépendances :
    sudo apt-get install libpoppler-qt5-1 libQt5Multimedia5 libpoppler-qt5-dev

    • H2L29 10 juillet 2014 / 19 h 19 min

      excellent reader, manque plus qu’une version android

      dépend de libpoppler-qt5-1 libqt5opengl5 libqt5multimedia5 libqt5network5 sous debian

      • Noireaude 10 juillet 2014 / 20 h 31 min

        En effet, ça serait cool :)

  5. Esclapion 9 juillet 2014 / 11 h 37 min

    Merci, j’adopte :)

  6. jbd 9 juillet 2014 / 9 h 14 min

    Bonjour,

    merci pour la présentation de l’outil. Quelles sont les boutiques en ligne permettant d’acheter des bandes dessinées numériques sans DRM et exploitable avec ce genre de logiciel ?

    • Noireaude 10 juillet 2014 / 20 h 32 min

      Bonne question :)

      • mikaji 11 juillet 2014 / 1 h 33 min

        humm humm, j’ai bien une réponse mais elle implique un manquement à la loi :)

        • Noireaude 11 juillet 2014 / 19 h 05 min

          Alors il vaut mieux éviter, tout précisant que le meilleur outil légal s’appelle Google, qui bien utilisé nous trouve tout. Je dis ça, je dis rien … ;)

          • mikaji 13 juillet 2014 / 11 h 47 min

            Pour ça que j’ai rien dit… :)

Comments are closed.